您当前的位置: 首页 > 养生

Wordpress28茬升级前後妳需婹知

2019-02-03 00:20:34

Wordpress 2.8于2009年6月10号(国内时间6月11号)正式发布了。在这个版本中有很多新特性与改进之处。对于Wordpress用户来说升级到版本是件好事。下面,我们就来总结一下一些重要的特性,以及在升级到版本前需要了解的一些事情。

先来看一下Wordpress官方中文站上对新版本的一个概述:

Wordpress 2.8 在主题、小工具支持、显示选项和运行速度上做了改进,修复了 790 bugs,增加了180个新特性。2.8的后台速度明显提升,现在在后台亦可安装主题,添加了一个新的 CodePress 器支持语法高亮,并且有语法参考。中文版的WordPress 2.8现在亦提供更新,更多的新鲜东西请安装升级看看,希望能给你带来惊喜。

在升级之前

在升级之前有两个判断标准是需要确认的:

插件兼容性

这可能是在升级2.8前需要确认的重要的事情。我们一般都会在wordpress搭建的blog中使用不少插件,例如用它们来改进站的SEO。如果使用的插件与wordpress 2.8不兼容,它有可能会让整个博客崩溃!Wordpress 2.8 Codex已经提供了一个清单,列出了通过Wordpress 2.8兼容性测试的插件。

除了Wordpress codex, BraveNewCode也为我们提供了Wordpress插件兼容性检查列表,列出了各个插件需要环境的更多信息。目前,这个列表包括了越5040个插件,下面是个截图:

If your plugins are not listed in the list, you better contact the plugin author before upgrade your Wordpress.

如果你使用的插件不在列表中,在升级Wordpress前联系下插件作者。

主题(皮肤)兼容性

确认了插件可以正常工作后,下一步要做的的检查你的当前主题与Wordpress 2.8是否兼容。绝大部分主题是应当与Wordpress 2.8兼容的,除非它的许多特性中用到了wordpress的动作钩子(action hooks)和大量的过滤器(filters)。你可以访问Wordpress Codex检查主题的兼容性。

在升级之后

当确认完插件和主题与Wordpress 2.8兼容后,你就可以升级Wordpress,享受它带给我们的新特性了。下面我们来看下Wordpress 2.8的主要改进之处:

主题安装

Wordpress 2.7中添加了插件安装器,使安装插件的工作变得便捷简单。同样的,在Wordpress 2.8中,添加了样式安装器(像wordpress 2.7中安装插件一样安装样式)。

你可以基于颜色、列数、宽度等特性查找主题。你可以在主题安装页面上传某个主题或浏览主题展画。Wordpress 2.8也添加了一键安装主题的功能。

更好的主题管理

在之前版本中,你不得不点击某个样式的截图,然后点击激活链接来使用某个主题。也就是说,在使用某个主题前必须先预览它。然而,预览可能会因为某个插件未找到或不兼容而被卡住,也就不可能再去使用这个主题。

现在,通过全新的主题管理系统,你可以通过连接轻松的完成主题激活、预览、删除操作。

改善主题/插件器中函数查找及语法高亮

如果使用过上个版本中内置的代码器,你会了解到新版本中有多少的改进。在继续潜看一下新的代码器样式:

如你在截图中看到的,新版本中添加了语法高亮和函数查找功能。函数查找会指引你到Wordpress文档。(不是Wordpress codex)

注:相关站建设技巧阅读请移步到建站教程频道。

木纹铝单板
青岛暖气片十大品牌
叶片泵
推荐阅读
图文聚焦